Instagram
youtube
Facebook
Twitter

Python itertools.combinations() HackerRank Solution

itertools.combinations(iterable, r)
This tool returns the  length subsequences of elements from the input iterable.

Combinations are emitted in lexicographic sorted order. So, if the input iterable is sorted, the combination tuples will be produced in sorted order.

Sample Code

>>> from itertools import combinations
>>> 
>>> print list(combinations('12345',2))
[('1', '2'), ('1', '3'), ('1', '4'), ('1', '5'), ('2', '3'), ('2', '4'), ('2', '5'), ('3', '4'), ('3', '5'), ('4', '5')]
>>> 
>>> A = [1,1,3,3,3]
>>> print list(combinations(A,4))
[(1, 1, 3, 3), (1, 1, 3, 3), (1, 1, 3, 3), (1, 3, 3, 3), (1, 3, 3, 3)]

Task

You are given a string S.
Your task is to print all possible combinations, up to size k, of the string in lexicographic sorted order.

Input Format

A single line containing the string S and integer value k separated by a space.

Constraints

0 < k < len(S)
The string contains only UPPERCASE characters.

Output Format

Print the different combinations of string S on separate lines.

Sample Input

HACK 2

Sample Output

A
C
H
K
AC
AH
AK
CH
CK
HK

Solution:

from itertools import combinations
word , length  = input().split()
for i in range(1, int(length)+1):
    for j in combinations(sorted(word), i):
        print (''.join(j))

Steps used in solving the problem - 

Step 1: First we imported combinations from itertools.
Step 2: then, we have taken the input of word and length.
Step 3: After this, we created a for loop in the range of 1 to (length+1).
Step 4: Inside for loop, we created another for loop and used the "combinations" method to make combinations and the "sorted" method to sort these combinations alphabetically.
Step 5: In the last step, we used the join method and printed our combinations.