Instagram
youtube
Facebook
Twitter

Python Find a string HackerRank Solution

Task

In this challenge, the user enters a string and a substring. You have to print the number of times that the substring occurs in the given string. String traversal will take place from left to right, not from right to left.

NOTE: String letters are case-sensitive.

Input Format

The first line of input contains the original string. The next line contains the substring.

Constraints

1 <= len(string) <= 200
Each character in the string is an ascii character.

Output Format

Output the integer number indicating the total number of occurrences of the substring in the original string.

Sample Input 0

ABCDCDC
CDC

Sample Output 0

2

Concept

Some string processing examples, such as these, might be useful.
There are a couple of new concepts:
In Python, the length of a string is found by the function len(s), where s is the string.
To traverse through the length of a string, use a for loop:

for i in range(0, len(s)):
    print (s[i])

A range function is used to loop over some length:

range (0, 5) 

Here, the range loops over 0 to 4. 5 is excluded.

Solution: 

def count_substring(string, sub_string):
    total = 0
    for i in range(len(string)):
        if string[i:len(string)].startswith(sub_string):
            total += 1
    return total

if __name__ == '__main__':
    string = input().strip()
    sub_string = input().strip()
    
    count = count_substring(string, sub_string)
    print(count)

Steps Used in solving the problem -

Step 1: First we created an function. this function takes a string & sub_string as input.
Step 2: then, we defined a variable to store the total.
Step 3: then, we created a for loop that iterates in the range of length of the string.
Step 4: Inside for loop, we had given an if condition to check if a string starts with a substring.
Step 5: In the last step, we returned our string.