Instagram
youtube
Facebook
Twitter

Python Polar Coordinates HackerRank Solution

Polar coordinates are an alternative way of representing Cartesian coordinates or Complex Numbers.

A complex number z: z = x+yj

is completely determined by its real part x and imaginary part y.
Here, j is the imaginary unit.

A polar coordinate (r,p) is completely determined by modulus r and phase angle p.

If we convert complex number z to its polar coordinate, we find:

r: Distance from z to origin, i.e., √x2+y2

p: Counter clockwise angle measured from the positive x-axis to the line segment that joins z to the origin.

Python's cmath module provides access to the mathematical functions for complex numbers.

cmath.python

This tool returns the phase of the complex number z (also known as the argument of z).

>>> phase(complex(-1.0, 0.0))
3.1415926535897931

abs

This tool returns the modulus (absolute value) of the complex number z.

>>> abs(complex(-1.0, 0.0))
1.0

Task

You are given a complex z. Your task is to convert it to polar coordinates.

Input Format

A single line containing the complex number z. Note: complex() function can be used in python to convert the input as a complex number.

Constraints

Given number is a valid complex number

Output Format

Output two lines:

The first line should contain the value of r.

The second line should contain the value of p.

Sample Input

  1+2j

Sample Output

 2.23606797749979 
 1.1071487177940904

Note: The output should be correct up to 3 decimal places.

Solution:

import cmath
n = input()
s = complex(n)
print(abs(s))
print(cmath.phase(s))

Steps Used in solving the problem -

Step 1: First we imported cmath.
Step 2: then we have taken the input of n.
Step 3: and we have defined n as a complex number.
Step 4: At last we used the abs function to print the absolute value of s and cmath.phase to print the phase value of s.