Instagram
youtube
Facebook
Twitter

Python Text Wrap HackerRank Solution

Task

You are given a string S and width w.

Your task is to wrap the string into a paragraph of width w.

Function Description

Complete the wrap function in the editor below.

wrap has the following parameters:

  • string string: a long string

  • int max_width: the width to wrap to

Returns

  • string: a single string with newline characters ('\n') where the breaks should be

Input Format

The first line contains a string, String.
The second line contains the width, Max_Width.

Constraints

  • 0 < len(string) < 1000

  • 0 < width < len(string)

Sample Input 0

 

ABCDEFGHIJKLIMNOQRSTUVWXYZ
4

Sample Output 0

ABCD
EFGH
IJKL
IMNO
QRST
UVWX
YZ

Solution:

import textwrap

def wrap(string, max_width):
    return textwrap.fill(string, max_width)

if __name__ == '__main__':
    string, max_width = input(), int(input())
    result = wrap(string, max_width)
    print(result)

What Is Textwrap?

Text wrap is a python module used to wrap and format plain text.

Steps Used in solving the problem -

Step 1: First we have imported textwrap.
Step 2: then, we created a function that takes a string and returns it wrapped in lines of max_width characters.
Step 3: in the final step we used the textwrap.fill function to wrap the given paragraph according to max_width.